summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mythes/mythes-1.2.5.ebuild')
-rw-r--r--app-text/mythes/mythes-1.2.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/mythes/mythes-1.2.5.ebuild b/app-text/mythes/mythes-1.2.5.ebuild
new file mode 100644
index 000000000000..e9e541fbdbd0
--- /dev/null
+++ b/app-text/mythes/mythes-1.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple thesaurus for LibreOffice"
+HOMEPAGE="https://github.com/hunspell/mythes"
+SRC_URI="https://github.com/hunspell/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="app-text/hunspell:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}