summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/namazu/namazu-2.0.22_p1.ebuild')
-rw-r--r--app-text/namazu/namazu-2.0.22_p1.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/app-text/namazu/namazu-2.0.22_p1.ebuild b/app-text/namazu/namazu-2.0.22_p1.ebuild
deleted file mode 100644
index 8889da50fc46..000000000000
--- a/app-text/namazu/namazu-2.0.22_p1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools elisp-common ltprune
-
-DESCRIPTION="Namazu is a full-text search engine"
-HOMEPAGE="http://www.namazu.org/"
-SRC_URI="http://www.namazu.org/test/${P/_p/pre}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="emacs l10n_ja nls static-libs tk"
-
-RDEPEND="dev-perl/File-MMagic
- emacs? ( virtual/emacs )
- l10n_ja? (
- app-i18n/nkf
- || (
- dev-perl/Text-Kakasi
- app-i18n/kakasi
- app-text/chasen
- app-text/mecab
- )
- )
- nls? ( virtual/libintl )
- tk? (
- dev-lang/tk:0
- www-client/lynx
- )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-S="${WORKDIR}"/${P/_p/pre}
-
-PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
-
-src_prepare() {
- default
-
- mv configure.{in,ac}
- mv tk${PN}/configure.{in,ac}
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_enable nls)
- $(use_enable static-libs static)
- $(use_enable tk tk${PN})
- )
- use tk && myconf+=(
- --with-${PN}="${EPREFIX}"/usr/bin/${PN}
- --with-mknmz="${EPREFIX}"/usr/bin/mknmz
- --with-indexdir="${EPREFIX}"/var/lib/${PN}/index
- )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake
-
- if use emacs; then
- cd lisp
- rm -f browse*
- elisp-compile *.el
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install
-
- if use emacs; then
- elisp-install ${PN} lisp/*.el*
- elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
-
- docinto lisp
- dodoc lisp/ChangeLog*
- fi
-
- prune_libtool_files
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}