summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/nfoview/nfoview-1.10.ebuild')
-rw-r--r--app-text/nfoview/nfoview-1.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/nfoview/nfoview-1.10.ebuild b/app-text/nfoview/nfoview-1.10.ebuild
new file mode 100644
index 000000000000..824ed221ddef
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
+
+inherit distutils fdo-mime gnome2-utils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
+ http://github.com/otsaloma/nfoview.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://download.gna.org/nfoview/1.10/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="http://home.gna.org/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}