summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/openpaperwork-gtk')
-rw-r--r--app-text/openpaperwork-gtk/Manifest4
-rw-r--r--app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.2.ebuild (renamed from app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild)5
-rw-r--r--app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.3.ebuild (renamed from app-text/openpaperwork-gtk/openpaperwork-gtk-2.1.2.ebuild)21
3 files changed, 20 insertions, 10 deletions
diff --git a/app-text/openpaperwork-gtk/Manifest b/app-text/openpaperwork-gtk/Manifest
index 5105be2f8cc7..1ebe22c85607 100644
--- a/app-text/openpaperwork-gtk/Manifest
+++ b/app-text/openpaperwork-gtk/Manifest
@@ -1,2 +1,2 @@
-DIST openpaperwork-gtk-2.1.2.tar.gz 59104 BLAKE2B 94782b0fbd29e749b68f277e5c48a8f194d4feafe2f1579615b51bed44855a9113631302e3ed0f8248683ba524e72147da7cdce76e54b266ae9d8dbaa5cba2a5 SHA512 9f11482e68ee01356644fc2a679044a835308f6591b1b3ef6fc079c26e87a5c8c7fa8ba23545e7bf7fc9d37d85151a70cd7bdf4c45c271f67f8a8dcf95a5c440
-DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
+DIST paperwork-2.2.2.tar.bz2 2531134 BLAKE2B 760d5fdc949ed44993c9845232e3f92b26b8dcb84ef82b08be7dbb0b262461feaf06f930f3fce0b94fdd8412a8264969bac117e3ea7aef70e1b47436a9dba3c0 SHA512 e0d3c24a0d611ffea231e129461d2925dc8318aaade185e83361bca8d1757e4601510db6122dc412863e617a387eb1c6008d0974c2b37be7ac4e4c3e68bc450b
+DIST paperwork-2.2.3.tar.bz2 2531208 BLAKE2B 6259a9b7a916ad71fc0f0747ce0c17e874dbff962c3d8b46c4c25c2a119de6d27f0ce7ce262dfbf7290fa436726fc538d9bead2664d7f158d51634eece768620 SHA512 68bad3ccc9ed2fdea2b1336945ca4f11de5b0a2249d5f043dc34d620ae5bf6627c0255d4776a5c19e9d266972403023f0b63eb3bf694d7a33051b53239c017bf
diff --git a/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild b/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.2.ebuild
index d3f68f150bd4..9537e32fc587 100644
--- a/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.1.ebuild
+++ b/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,6 +11,7 @@ inherit distutils-r1
DESCRIPTION="Paperwork plugins"
HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+S=${WORKDIR}/paperwork-${PV}/${PN}
LICENSE="GPL-3"
SLOT="0"
@@ -27,8 +28,6 @@ BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
sys-apps/which
sys-devel/gettext"
-S=${WORKDIR}/paperwork-${PV}/${PN}
-
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
python_compile() {
diff --git a/app-text/openpaperwork-gtk/openpaperwork-gtk-2.1.2.ebuild b/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.3.ebuild
index 7884f8b08f13..bfb9af9c2fcf 100644
--- a/app-text/openpaperwork-gtk/openpaperwork-gtk-2.1.2.ebuild
+++ b/app-text/openpaperwork-gtk/openpaperwork-gtk-2.2.3.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..13} )
-inherit distutils-r1 pypi
+inherit distutils-r1
DESCRIPTION="Paperwork plugins"
HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+S=${WORKDIR}/paperwork-${PV}/${PN}
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="app-text/openpaperwork-core[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
@@ -24,3 +24,14 @@ RDEPEND="app-text/openpaperwork-core[${PYTHON_USEDEP}]
gui-libs/libhandy
x11-libs/gtk+:3[introspection]"
DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-apps/which
+ sys-devel/gettext"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}