summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfarranger')
-rw-r--r--app-text/pdfarranger/Manifest4
-rw-r--r--app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild (renamed from app-text/pdfarranger/pdfarranger-1.10.0.ebuild)15
-rw-r--r--app-text/pdfarranger/pdfarranger-1.11.0.ebuild (renamed from app-text/pdfarranger/pdfarranger-1.9.2.ebuild)17
3 files changed, 15 insertions, 21 deletions
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 7fec608810bf..488595cf98cc 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1,2 +1,2 @@
-DIST pdfarranger-1.10.0.tar.gz 303125 BLAKE2B 126b47dfdabbe6d75331788dd891e1d8136a70b98e70601e19fd47fc7e3d81c350eb1fc8866a3a09db88b2b760ef964e7a01cf233464440c81a6dc5462101592 SHA512 92aa53a402d2f4c82a7f99f2acc1c328f71ad18835e524588e0f011f3ba8b074bf425ed881bb5f9ce3020833ce37cc3c301fd90b8931b44f909c8647bc1b09af
-DIST pdfarranger-1.9.2.tar.gz 280531 BLAKE2B 6a7a8e73e701fe9bbb5bd1f94411003dfb16966ad28522820a27e7ab554b3c2679eec3f4a08332bd58dc1c1cafd620e1daef2f39cb0f6dc5589d7bd5eb293650 SHA512 c22cc753e2606d90913970ce57462b4aca7c41fa6a9b6ece76b618800cad12bce808aba4a6fba2ef9698fda209e11799f30d091a88c9beb2e80a09ac7df51cb8
+DIST pdfarranger-1.10.1.tar.gz 304298 BLAKE2B 9762864072d4d75cf7e4a65f9ec9db040eef53ee97b2867340bc427d350f4b9b9fbc321520bf2e47d1c2ab2c866c8ceaf56b9806378bcdff4897ebc7f6c1e2ee SHA512 a0bebb569570656217e4f9432c0a3fbdb7f441b7ee04dc82f31e449befec19a1fa1045ef7ce95dc75e9feb14fad9a0265307efdf221c8a727091c05348554427
+DIST pdfarranger-1.11.0.tar.gz 450491 BLAKE2B a34323e2491412bd192ee49106008388170452fa2ff150c56a03573a18582e65457e213db2e0f33b909b6e442acd30f397a3167d560555f2d9b70a2b0daca985 SHA512 b5eb91ea0157453928e908fb13857929364d3cb0fa6872c1a2c2a60f654bebdeaf88da483071e52727dc1943f972fa78e919e4b46a63a131795018c125dfee48
diff --git a/app-text/pdfarranger/pdfarranger-1.10.0.ebuild b/app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild
index 44ebd2bc40e7..8ce2e410ae63 100644
--- a/app-text/pdfarranger/pdfarranger-1.10.0.ebuild
+++ b/app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1 optfeature xdg desktop
DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
@@ -14,21 +14,18 @@ SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64"
-IUSE=""
RDEPEND="
app-text/poppler[introspection,cairo]
- >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
dev-python/python-dateutil[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection]
"
-DEPEND="${RDEPEND}
- dev-python/python-distutils-extra[${PYTHON_USEDEP}]
- dev-util/intltool
-"
+DEPEND="${RDEPEND}"
src_install() {
distutils-r1_src_install
diff --git a/app-text/pdfarranger/pdfarranger-1.9.2.ebuild b/app-text/pdfarranger/pdfarranger-1.11.0.ebuild
index 44ebd2bc40e7..5bb0d5ee7a7a 100644
--- a/app-text/pdfarranger/pdfarranger-1.9.2.ebuild
+++ b/app-text/pdfarranger/pdfarranger-1.11.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1 optfeature xdg desktop
DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
@@ -13,22 +13,19 @@ SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
+KEYWORDS="~amd64"
RDEPEND="
app-text/poppler[introspection,cairo]
- >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
dev-python/python-dateutil[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection]
"
-DEPEND="${RDEPEND}
- dev-python/python-distutils-extra[${PYTHON_USEDEP}]
- dev-util/intltool
-"
+DEPEND="${RDEPEND}"
src_install() {
distutils-r1_src_install