summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/files/pelican-4.9.1-no-locales-for-tests.patch22
-rw-r--r--app-text/pelican/pelican-4.9.1.ebuild7
2 files changed, 29 insertions, 0 deletions
diff --git a/app-text/pelican/files/pelican-4.9.1-no-locales-for-tests.patch b/app-text/pelican/files/pelican-4.9.1-no-locales-for-tests.patch
new file mode 100644
index 000000000000..c7d917cdad6e
--- /dev/null
+++ b/app-text/pelican/files/pelican-4.9.1-no-locales-for-tests.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/863962
+https://git.alpinelinux.org/aports/tree/testing/py3-pelican/no-locales-for-tests.patch
+
+--- a/pelican/tests/support.py
++++ b/pelican/tests/support.py
+@@ -150,15 +150,7 @@
+
+
+ def locale_available(locale_):
+- old_locale = locale.setlocale(locale.LC_TIME)
+-
+- try:
+- locale.setlocale(locale.LC_TIME, str(locale_))
+- except locale.Error:
+- return False
+- else:
+- locale.setlocale(locale.LC_TIME, old_locale)
+- return True
++ return False
+
+
+ def can_symlink():
diff --git a/app-text/pelican/pelican-4.9.1.ebuild b/app-text/pelican/pelican-4.9.1.ebuild
index a8ec456458a6..ea20dc939423 100644
--- a/app-text/pelican/pelican-4.9.1.ebuild
+++ b/app-text/pelican/pelican-4.9.1.ebuild
@@ -47,11 +47,18 @@ BDEPEND="
DOCS=( README.rst )
+# For musl, bug 863962
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-no-locales-for-tests.patch" )
+
EPYTEST_DESELECT=(
# Needs investigation, we weren't running tests at all before
pelican/tests/test_testsuite.py::TestSuiteTest::test_error_on_warning
pelican/tests/test_pelican.py::TestPelican::test_basic_generation_works
pelican/tests/test_pelican.py::TestPelican::test_custom_generation_works
+
+ # For musl, bug 863962
+ # Per Alpine https://git.alpinelinux.org/aports/tree/testing/py3-pelican/APKBUILD
+ pelican/tests/test_contents.py::TestPage::test_datetime
)
distutils_enable_tests pytest