summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/restview/restview-2.2.0.ebuild')
-rw-r--r--app-text/restview/restview-2.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/restview/restview-2.2.0.ebuild b/app-text/restview/restview-2.2.0.ebuild
new file mode 100644
index 000000000000..8d96eb1f1adb
--- /dev/null
+++ b/app-text/restview/restview-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="reStructuredText viewer"
+HOMEPAGE="https://mg.pov.lt/restview/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGES.rst )
+
+python_test() {
+ esetup.py test
+}