summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/restview/restview-3.0.0.ebuild')
-rw-r--r--app-text/restview/restview-3.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/restview/restview-3.0.0.ebuild b/app-text/restview/restview-3.0.0.ebuild
new file mode 100644
index 000000000000..b26aed69c63b
--- /dev/null
+++ b/app-text/restview/restview-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="reStructuredText viewer"
+HOMEPAGE="
+ https://mg.pov.lt/restview/
+ https://pypi.org/project/restview/
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/readme-renderer[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGES.rst )
+
+distutils_enable_tests pytest