summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/scdoc/scdoc-1.10.0.ebuild')
-rw-r--r--app-text/scdoc/scdoc-1.10.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-text/scdoc/scdoc-1.10.0.ebuild b/app-text/scdoc/scdoc-1.10.0.ebuild
deleted file mode 100644
index 9460e30e3a9a..000000000000
--- a/app-text/scdoc/scdoc-1.10.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
-HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
- inherit git-r3
-else
- SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-src_prepare() {
- default
-
- sed -e 's/-Werror//' \
- -i Makefile || die 'Failed to patch Makefile'
-}
-
-src_compile() {
- local MY_HS="./scdoc"
- if tc-is-cross-compiler; then
- tc-export_build_env
- MY_HS="./hostscdoc"
- emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
- CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
- mv scdoc hostscdoc || die 'Failed to rename host scdoc'
- fi
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" \
- PCDIR="${ED}/usr/$(get_libdir)/pkgconfig" install
-}