summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tofrodos')
-rw-r--r--app-text/tofrodos/Manifest1
-rw-r--r--app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch17
-rw-r--r--app-text/tofrodos/metadata.xml12
-rw-r--r--app-text/tofrodos/tofrodos-1.7.12a.ebuild37
4 files changed, 67 insertions, 0 deletions
diff --git a/app-text/tofrodos/Manifest b/app-text/tofrodos/Manifest
new file mode 100644
index 000000000000..21c00b221620
--- /dev/null
+++ b/app-text/tofrodos/Manifest
@@ -0,0 +1 @@
+DIST tofrodos-1.7.12a.tar.gz 97588 SHA256 3098af78325486b99116c65c9f9bbbbfb3dfbeab1ab1e63a8da79550a5af6a08 SHA512 45a03203ccd053ec02a420fe4a63b427ee74dfa2c30e914836621a1cd7836ce81800e8bd5f1cccdb93233780ce79bc74d4ad49dca6192899b3039cf559baa8a2 WHIRLPOOL 73491c118a219a4cc25d2763b28a3cc10bcdaa08ae01a3cc99842254f6df3afb4662b25d2d73b1bb6e36408fc32007bc4a758361a5a951679c616fdae3f5aecb
diff --git a/app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch b/app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch
new file mode 100644
index 000000000000..5aa0e8358565
--- /dev/null
+++ b/app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch
@@ -0,0 +1,17 @@
+--- Makefile.original 2009-04-11 22:46:08.000000000 -0600
++++ Makefile 2009-04-12 14:30:55.000000000 -0600
+@@ -92,14 +92,10 @@
+ OBJS = emsg.o \
+ init.o \
+ tofrodos.o \
+ utility.o
+
+-# implicit rules
+-.c.o:
+- $(CC) $(CFLAGS) $<
+-
+ # user visible rules
+ all: $(FROMDOS) $(TODOS)
+
+ clean:
+ $(RM) $(OBJS)
diff --git a/app-text/tofrodos/metadata.xml b/app-text/tofrodos/metadata.xml
new file mode 100644
index 000000000000..3f2f97787b50
--- /dev/null
+++ b/app-text/tofrodos/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer>
+ <email>vostorga@gentoo.org</email>
+ <name>Victor Ostorga</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/tofrodos/tofrodos-1.7.12a.ebuild b/app-text/tofrodos/tofrodos-1.7.12a.ebuild
new file mode 100644
index 000000000000..49d73000aa89
--- /dev/null
+++ b/app-text/tofrodos/tofrodos-1.7.12a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="text file conversion utility that converts ASCII files between the
+MSDOS format and the Unix format"
+HOMEPAGE="http://tofrodos.sourceforge.net/"
+SRC_URI="http://tofrodos.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.8-CFLAGS.patch
+}
+
+src_compile() {
+ emake DEBUG=1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin fromdos
+ dosym fromdos /usr/bin/todos
+ doman fromdos.1
+}