summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xmltoman/xmltoman-0.4-r2.ebuild')
-rw-r--r--app-text/xmltoman/xmltoman-0.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/xmltoman/xmltoman-0.4-r2.ebuild b/app-text/xmltoman/xmltoman-0.4-r2.ebuild
new file mode 100644
index 000000000000..2364778f118c
--- /dev/null
+++ b/app-text/xmltoman/xmltoman-0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple scripts for converting xml to groff or html"
+HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ # 'make install' requires GNU install, upstream is dead and carrying
+ # a patch is more space than redoing it here
+ dobin xmltoman xmlmantohtml
+
+ insinto /usr/share/xmltoman
+ doins xmltoman.{css,dtd,xsl}
+
+ dodoc README
+ doman xmltoman.1 xmlmantohtml.1
+}