summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xournalpp/files/xournalpp-1.2.3-lua-5-4.patch')
-rw-r--r--app-text/xournalpp/files/xournalpp-1.2.3-lua-5-4.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-text/xournalpp/files/xournalpp-1.2.3-lua-5-4.patch b/app-text/xournalpp/files/xournalpp-1.2.3-lua-5-4.patch
new file mode 100644
index 000000000000..89784b96354f
--- /dev/null
+++ b/app-text/xournalpp/files/xournalpp-1.2.3-lua-5-4.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 453695c0..900c6cc3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -146,7 +146,7 @@ find_package(ZLIB REQUIRED)
+ find_package(Threads REQUIRED)
+
+ option(ENABLE_PLUGINS "Compile with plugin support" ON)
+-find_package(Lua) # Lua 5.4 is only supported with cmake >=3.18
++find_package(Lua ${LUA_VERSION} EXACT) # Lua 5.4 is only supported with cmake >=3.18
+ message(STATUS "Found Lua: ${Lua_FOUND}")
+ if (Lua_FOUND AND ENABLE_PLUGINS)
+ # currently not fully supported by cmake