summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
index 7353defff61e..421aa12c568d 100644
--- a/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
+++ b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
@@ -20,12 +20,18 @@ IUSE=""
RDEPEND+="!app-text/ronn"
-ruby_add_rdepend "
+DEPS="
>=dev-ruby/kramdown-2.1:2
- =dev-ruby/mustache-1*
>=dev-ruby/nokogiri-1.9.0:0
"
+ruby_add_rdepend "
+ =dev-ruby/mustache-1*
+ ${DEPS}
+"
+
+ruby_add_bdepend "${DEPS}"
+
all_ruby_prepare() {
sed -i -e '/mustache/ s/0.7/1.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
}