summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest2
-rw-r--r--app-text/poppler/poppler-22.01.0.ebuild126
-rw-r--r--app-text/poppler/poppler-22.02.0.ebuild126
3 files changed, 0 insertions, 254 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 82e20c9de2d5..e68fff1340a9 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -1,4 +1,2 @@
-DIST poppler-22.01.0.tar.xz 1801984 BLAKE2B f238636a0b1f07e0b70de99d8f0b3afcb7e2424c9dee4a044edaa5bd34753061e58a7c530792264ffb5a520cb4dc7dc52de17573fda350de97bef6346048fb76 SHA512 c6ea908a9188483ca588ac81d3e92dd15a405f90d36cc7059e618c8a7e3e9faeda82717aba5df34adb4a0a94e2fbecd472acec44972272349cc8d5a57b7405d1
-DIST poppler-22.02.0.tar.xz 1807024 BLAKE2B 97d27fb6d31535b5fce0aa518d00ab9da218a8d49dcb45dbaa5ab3cc669d8ffc75e07bd617b5fe9842c8b7b8ac843e9aa07ee0d31504f1e2b6c4f89b2177add6 SHA512 61867241d6d076dae554d654a8ad3b1a073079bad31f45170516b886fabb4c238ff2d49705924da219e128eb4052ac6337121967347600e54f61790dd0eed487
DIST poppler-22.03.0.tar.xz 1809940 BLAKE2B 0307e9225645b289105fe5a55a712ab821a0961a5dd53467b7db41432d74ec763e9ab0494f6b4d1bed94f7b0c2a74cb849878ad5f0c877fa4df0888f97a10ef6 SHA512 f87bbff4f394f192095da0c00bdf8b5c70b7eb864941225aad2025e91283c3c42a0016a772e7e9ea73a86746251928fc64500f923e8fd841adae1c6e67d72569
DIST poppler-22.05.0.tar.xz 1828628 BLAKE2B d1757893c841d35cbdeda493afea92046c447dfa0d519ab9a872a75fdb7edbb06bbde78b2e7d41757f5bbff8d1f46c81f7314dff8386d4d686ded4d2cc85d65e SHA512 629098793050f7a901c2a2cf1efcad83c58d26164cf94f4aa3985465f016a8875c62be4fb8ab8005ca00ef061402962e6d6c14eb611ce29f2d71d3ae83f24737
diff --git a/app-text/poppler/poppler-22.01.0.ebuild b/app-text/poppler/poppler-22.01.0.ebuild
deleted file mode 100644
index 47850488dd64..000000000000
--- a/app-text/poppler/poppler-22.01.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 2005-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs xdg-utils
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
- SLOT="0/9999"
-else
- SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/117" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
-fi
-
-DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
-HOMEPAGE="https://poppler.freedesktop.org/"
-
-LICENSE="GPL-2"
-IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
-
-# No test data provided
-RESTRICT="test"
-
-DEPEND="
- media-libs/fontconfig
- media-libs/freetype
- sys-libs/zlib
- cairo? (
- dev-libs/glib:2
- x11-libs/cairo
- introspection? ( dev-libs/gobject-introspection:= )
- )
- curl? ( net-misc/curl )
- jpeg? ( virtual/jpeg:0 )
- jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
- lcms? ( media-libs/lcms:2 )
- nss? ( >=dev-libs/nss-3.19:0 )
- png? ( media-libs/libpng:0= )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtxml:5
- )
- tiff? ( media-libs/tiff:0 )
-"
-RDEPEND="${DEPEND}
- cjk? ( app-text/poppler-data )
-"
-DEPEND+="
- boost? ( dev-libs/boost )
-"
-BDEPEND="
- dev-util/glib-utils
- virtual/pkgconfig
-"
-
-DOCS=( AUTHORS NEWS README.md README-XPDF )
-
-PATCHES=(
- "${FILESDIR}/${PN}-20.12.1-qt5-deps.patch"
- "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
- "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- # Clang doesn't grok this flag, the configure nicely tests that, but
- # cmake just uses it, so remove it if we use clang
- if tc-is-clang ; then
- sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
- fi
-
- if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
- sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
- -i CMakeLists.txt || die
- else
- einfo "policy(SET CMP0002 OLD) - workaround can be removed"
- fi
-}
-
-src_configure() {
- xdg_environment_reset
- local mycmakeargs=(
- -DBUILD_GTK_TESTS=OFF
- -DBUILD_QT5_TESTS=OFF
- -DBUILD_CPP_TESTS=OFF
- -DBUILD_MANUAL_TESTS=OFF
- -DRUN_GPERF_IF_PRESENT=OFF
- -DENABLE_BOOST="$(usex boost)"
- -DENABLE_ZLIB=ON
- -DENABLE_ZLIB_UNCOMPRESS=OFF
- -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
- -DUSE_FLOAT=OFF
- -DWITH_Cairo=$(usex cairo)
- -DENABLE_LIBCURL=$(usex curl)
- -DENABLE_CPP=$(usex cxx)
- -DWITH_JPEG=$(usex jpeg)
- -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
- -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
- -DENABLE_CMS=$(usex lcms lcms2 none)
- -DWITH_NSS3=$(usex nss)
- -DWITH_PNG=$(usex png)
- $(cmake_use_find_package qt5 Qt5Core)
- -DWITH_TIFF=$(usex tiff)
- -DENABLE_UTILS=$(usex utils)
- -DENABLE_QT6=OFF
- )
- use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # live version doesn't provide html documentation
- if use cairo && use doc && [[ ${PV} != *9999* ]]; then
- # For now install gtk-doc there
- insinto /usr/share/gtk-doc/html/poppler
- doins -r "${S}"/glib/reference/html/*
- fi
-}
diff --git a/app-text/poppler/poppler-22.02.0.ebuild b/app-text/poppler/poppler-22.02.0.ebuild
deleted file mode 100644
index 35b2f4f41bef..000000000000
--- a/app-text/poppler/poppler-22.02.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 2005-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs xdg-utils
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
- SLOT="0/9999"
-else
- SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/118" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
-fi
-
-DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
-HOMEPAGE="https://poppler.freedesktop.org/"
-
-LICENSE="GPL-2"
-IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
-
-# No test data provided
-RESTRICT="test"
-
-DEPEND="
- media-libs/fontconfig
- media-libs/freetype
- sys-libs/zlib
- cairo? (
- dev-libs/glib:2
- x11-libs/cairo
- introspection? ( dev-libs/gobject-introspection:= )
- )
- curl? ( net-misc/curl )
- jpeg? ( virtual/jpeg:0 )
- jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
- lcms? ( media-libs/lcms:2 )
- nss? ( >=dev-libs/nss-3.19:0 )
- png? ( media-libs/libpng:0= )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtxml:5
- )
- tiff? ( media-libs/tiff:0 )
-"
-RDEPEND="${DEPEND}
- cjk? ( app-text/poppler-data )
-"
-DEPEND+="
- boost? ( dev-libs/boost )
-"
-BDEPEND="
- dev-util/glib-utils
- virtual/pkgconfig
-"
-
-DOCS=( AUTHORS NEWS README.md README-XPDF )
-
-PATCHES=(
- "${FILESDIR}/${PN}-20.12.1-qt5-deps.patch"
- "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
- "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- # Clang doesn't grok this flag, the configure nicely tests that, but
- # cmake just uses it, so remove it if we use clang
- if tc-is-clang ; then
- sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
- fi
-
- if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
- sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
- -i CMakeLists.txt || die
- else
- einfo "policy(SET CMP0002 OLD) - workaround can be removed"
- fi
-}
-
-src_configure() {
- xdg_environment_reset
- local mycmakeargs=(
- -DBUILD_GTK_TESTS=OFF
- -DBUILD_QT5_TESTS=OFF
- -DBUILD_CPP_TESTS=OFF
- -DBUILD_MANUAL_TESTS=OFF
- -DRUN_GPERF_IF_PRESENT=OFF
- -DENABLE_BOOST="$(usex boost)"
- -DENABLE_ZLIB=ON
- -DENABLE_ZLIB_UNCOMPRESS=OFF
- -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
- -DUSE_FLOAT=OFF
- -DWITH_Cairo=$(usex cairo)
- -DENABLE_LIBCURL=$(usex curl)
- -DENABLE_CPP=$(usex cxx)
- -DWITH_JPEG=$(usex jpeg)
- -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
- -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
- -DENABLE_CMS=$(usex lcms lcms2 none)
- -DWITH_NSS3=$(usex nss)
- -DWITH_PNG=$(usex png)
- $(cmake_use_find_package qt5 Qt5Core)
- -DWITH_TIFF=$(usex tiff)
- -DENABLE_UTILS=$(usex utils)
- -DENABLE_QT6=OFF
- )
- use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # live version doesn't provide html documentation
- if use cairo && use doc && [[ ${PV} != *9999* ]]; then
- # For now install gtk-doc there
- insinto /usr/share/gtk-doc/html/poppler
- doins -r "${S}"/glib/reference/html/*
- fi
-}