summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/djvu/Manifest1
-rw-r--r--app-text/djvu/djvu-3.5.27-r2.ebuild73
-rw-r--r--app-text/djvu/djvu-3.5.28.ebuild65
3 files changed, 0 insertions, 139 deletions
diff --git a/app-text/djvu/Manifest b/app-text/djvu/Manifest
index fa7f8b1800d9..7853bec4b21a 100644
--- a/app-text/djvu/Manifest
+++ b/app-text/djvu/Manifest
@@ -1,2 +1 @@
-DIST djvu-3.5.27.zip 3567522 BLAKE2B c074468a2fedf097b9b8fea4c449f26b61bffb31d10114081554e59256a23315ecffc203b5223468ca0c3338118b53aba65eee4cb5e7ad5c8d55470e90f43843 SHA512 dc1cd1bce2fb6245946f9409b3a3826ef2dc77a20be079c929b17508c3d967a0b5d8acd61bad00357e46a845f7f97717a043db9ffd1fe23e9a09441b7d21cbd6
DIST djvulibre-3.5.28.tar.gz 3701161 BLAKE2B 74681f00d5f116ab08ccadb6c6f536f5d23f1fafdfae1239add6d800c0446298e65cd5dad293e28aa4d309dc93eaeec9036a7144f6fa42ff1104a4b945ca6bce SHA512 db3b8a5b56d700e911be32057f721a2a597e6f52e6fade203ad75ad76ab2d8facff2e474fd18beea703ccd5fa6425352e619a8fda40e69add1724dbee26050c6
diff --git a/app-text/djvu/djvu-3.5.27-r2.ebuild b/app-text/djvu/djvu-3.5.27-r2.ebuild
deleted file mode 100644
index 2887ff6e9fbf..000000000000
--- a/app-text/djvu/djvu-3.5.27-r2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools desktop flag-o-matic optfeature xdg-utils
-
-COMMIT="a00b7618c22fb35b030582147a4479c4cf41c349"
-MY_P="${PN}-${PN}libre-git-${COMMIT}"
-
-DESCRIPTION="DjVu viewers, encoders and utilities"
-HOMEPAGE="http://djvu.sourceforge.net/"
-SRC_URI="https://ajakk.github.io/${P}-${COMMIT}.zip -> ${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug doc jpeg tiff xml"
-
-RDEPEND="jpeg? ( virtual/jpeg:0 )
- tiff? ( media-libs/tiff:0= )"
-DEPEND="${RDEPEND}
- || ( gnome-base/librsvg media-gfx/inkscape )"
-BDEPEND="app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
-
- # We install all desktop files by hand.
- econf \
- $(use_enable xml xmltools) \
- $(use_with jpeg) \
- $(use_with tiff) \
- --disable-desktopfiles
-}
-
-DOCS=( NEWS README )
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- use doc && dodoc -r doc
-
- # Install desktop files.
- cd desktopfiles
- for i in {22,32,48,64}; do
- insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
- newins prebuilt-hi${i}-djvu.png image-vnd.djvu.png
- done
- insinto /usr/share/mime/packages
- doins djvulibre-mime.xml
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
- has_version app-text/djview || \
- optfeature "djviewer or browser plugin" app-text/djview
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
diff --git a/app-text/djvu/djvu-3.5.28.ebuild b/app-text/djvu/djvu-3.5.28.ebuild
deleted file mode 100644
index 1a910c109796..000000000000
--- a/app-text/djvu/djvu-3.5.28.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools desktop flag-o-matic optfeature xdg
-
-MY_P="${PN}libre-${PV#*_p}"
-DESCRIPTION="DjVu viewers, encoders and utilities"
-HOMEPAGE="http://djvu.sourceforge.net/"
-SRC_URI="http://downloads.sourceforge.net/djvu/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P%%.3}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug doc jpeg tiff xml"
-
-RDEPEND="jpeg? ( virtual/jpeg:0 )
- tiff? ( media-libs/tiff:0= )"
-DEPEND="${RDEPEND}
- || ( gnome-base/librsvg media-gfx/inkscape )"
-BDEPEND="app-arch/unzip"
-
-DOCS=( NEWS README )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
-
- # We install all desktop files by hand.
- econf \
- $(use_enable xml xmltools) \
- $(use_with jpeg) \
- $(use_with tiff) \
- --disable-desktopfiles
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- use doc && dodoc -r doc
-
- # Install desktop files.
- cd desktopfiles || die
- for i in {22,32,48,64}; do
- insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
- newins prebuilt-hi${i}-djvu.png image-vnd.djvu.png
- done
-
- insinto /usr/share/mime/packages
- doins djvulibre-mime.xml
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "djviewer or browser plugin" app-text/djview
-}