summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libqxp/Manifest1
-rw-r--r--app-text/libqxp/libqxp-0.0.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/libqxp/Manifest b/app-text/libqxp/Manifest
index ce3b3b1ccc03..14d19badb9ef 100644
--- a/app-text/libqxp/Manifest
+++ b/app-text/libqxp/Manifest
@@ -1 +1,2 @@
DIST libqxp-0.0.1.tar.xz 340184 BLAKE2B 759e5d0fb5886485f4ebe4a6caa34d1d98dc623c0ae124c6666a1be5ce7fb73686fc83360712d59d020e4788b39aa57d32149b7641d71b73dde917df46617f17 SHA512 a03a9ada658a92f4d985cad91d467b3916334c74dc26c1e4de89e3929e0135ca0e9c7e7e18ce616ef56a67863ec19c2638494400785849017f9a4776df07c607
+DIST libqxp-0.0.2.tar.xz 341760 BLAKE2B e596b3ebd23c8fff2a1675b1076ba6b4403bb41358972b50eb946610108f5968ef3e553478aec8c6211f8b476030033e7d334cb4deccc7d6bdfba3914821abf5 SHA512 409d3df82ac522b39bdd0ef4f0a781b906e246a8e6f502009c095eea90d672c482a7fc5c7f998d89952bc598c6f51357346ed6df490c25cb48e1318e27c50dab
diff --git a/app-text/libqxp/libqxp-0.0.2.ebuild b/app-text/libqxp/libqxp-0.0.2.ebuild
new file mode 100644
index 000000000000..f1095915cd1f
--- /dev/null
+++ b/app-text/libqxp/libqxp-0.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library parsing QuarkXpress documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug doc test tools"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/icu:=
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-weffc
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable test tests)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}