summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/paperwork/paperwork-1.2.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/paperwork/paperwork-1.2.4-r1.ebuild b/app-text/paperwork/paperwork-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..9156358a08b7
--- /dev/null
+++ b/app-text/paperwork/paperwork-1.2.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="~app-text/paperwork-backend-${PV}[${PYTHON_USEDEP}]
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyinsane:2[${PYTHON_USEDEP}]
+ >=dev-python/pyocr-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+DEPEND="${RDEPEND}"