summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lv/lv-4.51-r3.ebuild12
-rw-r--r--app-text/lv/lv-4.51-r4.ebuild21
2 files changed, 17 insertions, 16 deletions
diff --git a/app-text/lv/lv-4.51-r3.ebuild b/app-text/lv/lv-4.51-r3.ebuild
index b7a63bf3f3aa..ad9d48b78c38 100644
--- a/app-text/lv/lv-4.51-r3.ebuild
+++ b/app-text/lv/lv-4.51-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -16,18 +16,20 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
-RDEPEND="sys-libs/ncurses
- !app-editors/levee"
+RDEPEND="!app-editors/levee
+ sys-libs/ncurses"
DEPEND="${RDEPEND}
dev-lang/perl"
S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-xz.diff
- epatch "${FILESDIR}"/${P}-tinfo.patch
epatch "${FILESDIR}"/${P}-protos.patch
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ epatch "${FILESDIR}"/${P}-xz.diff
+
cd "${S}"/src
+ mv configure.{in,ac}
eautoreconf
}
diff --git a/app-text/lv/lv-4.51-r4.ebuild b/app-text/lv/lv-4.51-r4.ebuild
index a1b366d3665c..f85c10324f2b 100644
--- a/app-text/lv/lv-4.51-r4.ebuild
+++ b/app-text/lv/lv-4.51-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
-inherit autotools eutils toolchain-funcs
+inherit autotools toolchain-funcs
MY_P="${PN}${PV//./}"
@@ -16,27 +16,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
-RDEPEND="sys-libs/ncurses:0=
- !app-editors/levee"
+RDEPEND="!app-editors/levee
+ sys-libs/ncurses:0="
DEPEND="${RDEPEND}
dev-lang/perl"
-
S="${WORKDIR}/${MY_P}"
-DOCS=(README hello.sample)
-HTML_DOCS=(index.html relnote.html hello.sample.gif)
-
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-xz.diff
- "${FILESDIR}"/${P}-tinfo.patch
"${FILESDIR}"/${P}-protos.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-xz.diff
)
+DOCS=( README hello.sample )
+HTML_DOCS=( index.html relnote.html hello.sample.gif )
src_prepare() {
default
cd src
+ mv configure.{in,ac}
eautoreconf
}