summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libgxps/Manifest1
-rw-r--r--app-text/libgxps/libgxps-0.3.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/libgxps/Manifest b/app-text/libgxps/Manifest
index f74dd13b60a1..2d84af712481 100644
--- a/app-text/libgxps/Manifest
+++ b/app-text/libgxps/Manifest
@@ -1 +1,2 @@
DIST libgxps-0.2.5.tar.xz 346532 SHA256 3e7594c5c9b077171ec9ccd3ff2b4f4c4b29884d26d4f35e740c8887b40199a0 SHA512 f449c4cb989910797c84614ce9f141d4e9adcda0c18f309f656de397ba5deabfa9b4c558c81be7f52bc44c048c401616775989cd1ff9408eeea44f46ef56635b WHIRLPOOL db7514e785f46a3fbf32db9962c2644837855116acbbf37373388c3cfed3b88645c4a574fe8e2ae41913b68250d9448dd3566d9b15b258c74810262f4411f9b8
+DIST libgxps-0.3.0.tar.xz 93000 SHA256 412b1343bd31fee41f7204c47514d34c563ae34dafa4cc710897366bd6cd0fae SHA512 283ce3041f0238ef1dcae30ce2adbc3f843677e00ae22f20ed3459828f3edaab6d05d87c20dddb613925ab248ed0b29855a94198b982606c3dcb2e59f800b013 WHIRLPOOL 00b8544245bc6be3d2a8d183a35f3f4936951fdc3772d1c7ee893ce5fe97712bc472d0ab3ff670c35655bb8f93941e9687d54e3b503075929958bc492c6fa42e
diff --git a/app-text/libgxps/libgxps-0.3.0.ebuild b/app-text/libgxps/libgxps-0.3.0.ebuild
new file mode 100644
index 000000000000..275faeeef86c
--- /dev/null
+++ b/app-text/libgxps/libgxps-0.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+introspection jpeg lcms tiff"
+
+RDEPEND="
+ >=app-arch/libarchive-2.8
+ >=dev-libs/glib-2.36:2
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=x11-libs/cairo-1.10[svg]
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ tiff? ( media-libs/tiff:0[zlib] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-test=false
+ -Denable-gtk-doc=false
+ -Denable-man=true
+ -Ddisable-introspection=$(usex introspection false true)
+ -Dwith-liblcms2=$(usex lcms true false)
+ -Dwith-libjpeg=$(usex jpeg true false)
+ -Dwith-libtiff=$(usex tiff true false)
+ )
+
+ meson_src_configure
+}