summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/chasen/Manifest2
-rw-r--r--app-text/chasen/chasen-2.4.5.ebuild (renamed from app-text/chasen/chasen-2.4.4-r3.ebuild)4
-rw-r--r--app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch21
3 files changed, 2 insertions, 25 deletions
diff --git a/app-text/chasen/Manifest b/app-text/chasen/Manifest
index de495ce1cb55..0a4c5e4b144c 100644
--- a/app-text/chasen/Manifest
+++ b/app-text/chasen/Manifest
@@ -1 +1 @@
-DIST chasen-2.4.4.tar.gz 845720 BLAKE2B ae18e71d78588c108f747abc6f28835f90d0a2c84616a01d87acea2ae5e0e54ef6ff296ebb9dbdce9047a223bd34203cf2763e9b3d4fb28522a4add7bc823860 SHA512 4551d28be6c0de7a585decf03cf5b56def3d181cfdfd975565ac7236e2c3e8cc0bcf5331f1ae309a914f95c6715e13ba3e9d80ebbd6e86c2316a43b7ed831075
+DIST chasen-2.4.5.tar.xz 671064 BLAKE2B 3b9867f794a54c4b0552807c54694e9f52082d9712c9e64aa55840b70f3a3800a514d1cd36260ee7397d1e98f28909e9b3e1f5c14d64f28f666b876e130aeb3e SHA512 7a17fe9d534cdc07c147fd7d9350aba381390943f4cfd899393076efe8e6a80aae029a8d4833e91ffa945b3e52d6598c16db257c9cc8d7792b7a1f90b7a1948e
diff --git a/app-text/chasen/chasen-2.4.4-r3.ebuild b/app-text/chasen/chasen-2.4.5.ebuild
index 2e8a2e5f4013..48d64ea7ef9a 100644
--- a/app-text/chasen/chasen-2.4.4-r3.ebuild
+++ b/app-text/chasen/chasen-2.4.5.ebuild
@@ -7,7 +7,7 @@ inherit perl-module
DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
HOMEPAGE="https://chasen-legacy.osdn.jp/"
-SRC_URI="mirror://sourceforge.jp/${PN}-legacy/32224/${P}.tar.gz"
+SRC_URI="mirror://sourceforge.jp/${PN}-legacy/56305/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
@@ -18,8 +18,6 @@ RDEPEND="virtual/libiconv"
DEPEND=">=dev-libs/darts-0.32"
PDEPEND=">=app-dicts/ipadic-2.7.0"
-PATCHES=( "${FILESDIR}"/${P}-cve-2011-4000.patch )
-
src_configure() {
econf $(use_enable static-libs static)
diff --git a/app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch b/app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch
deleted file mode 100644
index 61480622e40a..000000000000
--- a/app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/lib/chalib.c b/lib/chalib.c
-index 5d79e13..cddf51b 100644
---- a/lib/chalib.c
-+++ b/lib/chalib.c
-@@ -306,9 +306,14 @@ chasen_sparse_main(char *input, FILE *output)
- */
- while (*input) {
- int c = 0, len, cursor;
-- if ((crlf = strpbrk(input, "\r\n")) == NULL)
-+ if ((crlf = strpbrk(input, "\r\n")) == NULL) {
- len = strlen(input);
-- else {
-+ if (len >= CHA_INPUT_SIZE) {
-+ len = CHA_INPUT_SIZE - 1;
-+ crlf = input + CHA_INPUT_SIZE - 2;
-+ c = 0;
-+ }
-+ } else {
- len = crlf - input;
- c = *crlf;
- *crlf = '\0';