summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdfarranger/Manifest1
-rw-r--r--app-text/pdfarranger/pdfarranger-1.9.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 03630e69ae7c..d007ffa7c0b6 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1 +1,2 @@
DIST pdfarranger-1.8.2.tar.gz 258995 BLAKE2B 019d41e6c89ee4e7a93bd4be9aa593bebf00c3489bae5db46f201e519e7dbd6c011ac5b15ba6450906a8e8ef8610dc9083c32b01fb88828281c0206e32c9d601 SHA512 e0b1ed59158681766e6b707a207363a8ccd38bdc76311600d338ef443e0ee79405af6afb65b878a68d7e52d2ea35f6a7aa700d9aaf46b31bcf64fd863c8784f2
+DIST pdfarranger-1.9.1.tar.gz 279138 BLAKE2B 18ac9a63eff5455e395b3c126adea590b230b1884ee64e08eeaf4951c663787a827e42db9475632210b2ca3875a23e1718fdfc1b4309c5babc7ce31b6e188829 SHA512 ba60744f1b7c96ca9f86ed75cc5ea1b3df41af162048550a916a96972b0e987acfbdc3c46693adc239fdad5569369f24555e157a2f56936374ba132ffc8cbde6
diff --git a/app-text/pdfarranger/pdfarranger-1.9.1.ebuild b/app-text/pdfarranger/pdfarranger-1.9.1.ebuild
new file mode 100644
index 000000000000..9f1c50faa734
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}