summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/breakpts')
-rw-r--r--app-vim/breakpts/Manifest1
-rw-r--r--app-vim/breakpts/breakpts-4.0.ebuild22
-rw-r--r--app-vim/breakpts/metadata.xml5
3 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/breakpts/Manifest b/app-vim/breakpts/Manifest
new file mode 100644
index 000000000000..4a3e677964ee
--- /dev/null
+++ b/app-vim/breakpts/Manifest
@@ -0,0 +1 @@
+DIST breakpts-4.0.tar.bz2 17349 SHA256 ef2f7b1ba7d1b6c7e691c028599c5b531bc78aeb79001a724a0ed1c22e237d79 SHA512 a480bf32cd3e756ac25849b1d5fd20521bd8c965454bb94c33810c9d1d4464762a731d08dcae858c59853a6cf41ab3cb6cddeda440c8b041cc8ec192ab2bd2fd WHIRLPOOL 7114a7aaf9d5f6bc991392dae8e7b2ee6b83e89e08a9146dcd3d2d1e6d15dd8d5b9a985d10cc5fbf304e4108e3e8f70c85789eec624e1983fe49c3b0cf238907
diff --git a/app-vim/breakpts/breakpts-4.0.ebuild b/app-vim/breakpts/breakpts-4.0.ebuild
new file mode 100644
index 000000000000..70d2dd10937c
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=618"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."
diff --git a/app-vim/breakpts/metadata.xml b/app-vim/breakpts/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/breakpts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>