summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/csound-syntax')
-rw-r--r--app-vim/csound-syntax/Manifest1
-rw-r--r--app-vim/csound-syntax/csound-syntax-20160804.ebuild20
-rw-r--r--app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch9
3 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/csound-syntax/Manifest b/app-vim/csound-syntax/Manifest
index 74e4283aacd2..9c446c2c12d5 100644
--- a/app-vim/csound-syntax/Manifest
+++ b/app-vim/csound-syntax/Manifest
@@ -1 +1,2 @@
+DIST csound-syntax-20160804.tar.bz2 326658 SHA256 b222e1b55945e4ccc1c11c55c3e9c8dae4c2a34c61bda80efaab508896416935 SHA512 83ba89768be3d9e5dd701cc8323fbbff75ce399210891fc1e5676e278c39cfdb4b5e4a354c93c1f439a667d0ea65f459aea0b6f79740a061381e22d2557c0eb8 WHIRLPOOL 61963663791405565263dcab85f8be64d45fffa522ca7a7e7c749c8d8316943bd215b04266eac92171a5f942833ed3455f88893198adbd605ed0b092d2267dd1
DIST csound-syntax-3.1.tar.bz2 39643 SHA256 123643a4118341f6ca44ebdd7ccddd82e2a3d5b4696db7b674a8043814de11dd SHA512 b82236a8502c3b9eb0fb98c1a34d992b329933a51a981bd213d3ab82fd73cb9ffb354b7786d69ee53a8ee8df02bf4ac4364569f5850af0581dbea72fe1471ed0 WHIRLPOOL 55ced201b86af9dee0f0f2c7239428cfd3b39a27bb0a2cbee955490ebe6992192898b41b1c1223e2a716eaae03641eec25a8a522fc38d1735bcf261e1269658a
diff --git a/app-vim/csound-syntax/csound-syntax-20160804.ebuild b/app-vim/csound-syntax/csound-syntax-20160804.ebuild
new file mode 100644
index 000000000000..0c4ca0189415
--- /dev/null
+++ b/app-vim/csound-syntax/csound-syntax-20160804.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit vim-plugin
+
+DESCRIPTION="set of tools for editing Csound files with vim"
+HOMEPAGE="https://github.com/luisjure/csound"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-doc.patch )
+
+src_prepare() {
+ rm LICENSE README.md || die
+ default
+}
diff --git a/app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch b/app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch
new file mode 100644
index 000000000000..c2cc7eccbad1
--- /dev/null
+++ b/app-vim/csound-syntax/files/csound-syntax-20160804-doc.patch
@@ -0,0 +1,9 @@
+--- csound-syntax-20160804/doc/csound.txt
++++ csound-syntax-20160804/doc/csound.txt
+@@ -1,4 +1,6 @@
++*csound.txt* Csound Syntax Reference
+
++ *csound-syntax*
+ ===========================================================================
+ != *!=*
+