summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/showmarks/showmarks-2.2-r2.ebuild')
-rw-r--r--app-vim/showmarks/showmarks-2.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/showmarks/showmarks-2.2-r2.ebuild b/app-vim/showmarks/showmarks-2.2-r2.ebuild
new file mode 100644
index 000000000000..ee89f462e9de
--- /dev/null
+++ b/app-vim/showmarks/showmarks-2.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: show location marks visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=152"
+
+LICENSE="public-domain"
+KEYWORDS="~alpha amd64 ~ia64 ~mips ppc sparc x86"
+
+VIM_PLUGIN_HELPFILES="showmarks.txt"
+
+src_prepare() {
+ default
+
+ mkdir "${S}"/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic HelpExtractor' variant. This causes
+ # problems for us during the unmerge. Fortunately, sed can fix this
+ # for us.
+ sed -e '1,/^" HelpExtractorDoc:$/d' \
+ "${S}"/plugin/showmarks.vim > "${S}"/doc/showmarks.txt \
+ || die "help extraction failed"
+ sed -i -e '/^" HelpExtractor:$/,$d' "${S}"/plugin/showmarks.vim \
+ || die "help extract remove failed"
+}