summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/snipmate/snipmate-0.87-r1.ebuild')
-rw-r--r--app-vim/snipmate/snipmate-0.87-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/snipmate/snipmate-0.87-r1.ebuild b/app-vim/snipmate/snipmate-0.87-r1.ebuild
new file mode 100644
index 000000000000..0b69d76294ee
--- /dev/null
+++ b/app-vim/snipmate/snipmate-0.87-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: TextMate-style snippets"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2540 https://github.com/garbas/vim-snipmate"
+SRC_URI="https://github.com/garbas/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-vim/vim-addon-mw-utils
+ app-vim/tlib
+"
+
+S=${WORKDIR}/${MY_P}
+
+VIM_PLUGIN_HELPFILES="SnipMate"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ rm addon-info.json || die
+}