summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vim-flake8/vim-flake8-1.7.ebuild')
-rw-r--r--app-vim/vim-flake8/vim-flake8-1.7.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-vim/vim-flake8/vim-flake8-1.7.ebuild b/app-vim/vim-flake8/vim-flake8-1.7.ebuild
new file mode 100644
index 000000000000..b8772d16ea7d
--- /dev/null
+++ b/app-vim/vim-flake8/vim-flake8-1.7.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: runs the currently open file through flake8"
+HOMEPAGE="https://github.com/nvie/vim-flake8"
+SRC_URI="https://github.com/nvie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/flake8"