summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild')
-rw-r--r--app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
new file mode 100644
index 000000000000..4d8504e4b3a0
--- /dev/null
+++ b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+# Commit Date: 16 Apr 2014
+COMMIT="f2afd55704bfe0a2d66e6b270d247e9b8a7b1664"
+
+DESCRIPTION="vim plugin: collection of vimscripts for Haskell development"
+HOMEPAGE="https://github.com/dag/vim2hs"
+SRC_URI="https://github.com/dag/vim2hs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/ghc"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ # We want a stripped-down version of these.
+ local f
+ for f in screenshots/*; do
+ bzip2 -9 "${f}" || die
+ done
+ vim-plugin_src_install
+}