summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild')
-rw-r--r--app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild b/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild
new file mode 100644
index 000000000000..4da686912fca
--- /dev/null
+++ b/app-vim/xquery-syntax/xquery-syntax-0.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: XQuery syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=803"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for XQuery files."
+
+src_prepare() {
+ default
+ # use hi def link. Bug #101788, bug #101804.
+ sed -i -e 's,^hi\(ghlight\)\? link,hi def link,' syntax/xquery.vim \
+ || die "sed failed"
+}