summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-9.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 4914ac338387..508af9ec6d14 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -3,3 +3,4 @@ DIST gentoo-syntax-5.tar.bz2 20386 BLAKE2B 8f5ba5bdf4a5caff400d4af0f0e88b2bfe36a
DIST gentoo-syntax-6.tar.bz2 21077 BLAKE2B 76d3cfff7eb8c6ea393770126eef8a39df010292edd95bf2599e0a341cd4d7399b17c27a1d3dfdc420268c9c3f14b8cd477b325c7b9525c547c5ae1b864061c3 SHA512 97792795d42f3fdb42bf8d1d2b531e47bbed463f14d2acdb1e801b96c980829dfd2a858f7b46d48892152b36f22ec0e478f6bb7ee374cdd3c69d7316641aa307
DIST gentoo-syntax-7.tar.bz2 21068 BLAKE2B c8b171486922f617a036f8d766183cbf3193093ed3cb8a87e69505439eb6cbeadbf9878a2283cf4f36f16f92079b2c65e687713cb77ebd7230509dc55d4f2473 SHA512 4c4b81ab72cff9d48c4ccd6b563edcdf0863d2de3ed4a6b9dd657badc059f58baf4cfe88e89d1f9afc5a91f0ce9b0be44346c1a62d5d737f638efec4ec593e24
DIST gentoo-syntax-8.tar.bz2 21280 BLAKE2B 81854e79fe206fda53cd4566c9e761fbac321929bfbaa7adb042750df60646a9ff494fb623af1d6540722fd0bb37106fbb8e50a7f0f602989adff3d88a58f41e SHA512 af3719dac995064861ba369786206433d92275d586e407f0d6b92f37cbb9f4b96a73b24193d21f59c6398cf51857f1292e4e2c647f0ee70d141db68c7db80b87
+DIST gentoo-syntax-9.tar.bz2 20901 BLAKE2B d510fdc3a0d06e1da4591f5a708f54a1892c3476e20cf16dc4d69d7583f284ef1fc1a25cdfbff81716f011eb61000e2b07a8adf61ef8f9cd2c961df47316bbb0 SHA512 c74af6fb29055a56937ded38e20ec4320c1c2c54af4f09e5225fa6fe3b59b95645470ccad0664bb0f44557a2baedff6ecea4b1042417f763f5e26cc06b0da61e
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-9.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-9.ebuild
new file mode 100644
index 000000000000..c560022b6db4
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}