summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/voom/Manifest1
-rw-r--r--app-vim/voom/voom-5.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/voom/Manifest b/app-vim/voom/Manifest
index 12e5f6a3be10..4cb36bbff9c4 100644
--- a/app-vim/voom/Manifest
+++ b/app-vim/voom/Manifest
@@ -1 +1,2 @@
DIST voom-5.1.tar.bz2 102211 BLAKE2B 3835fb8f41638ca2ff91c106d94ee04aca3b6b3efcb44c7f023faba164512a96ff5b310b6fba3604ba2abe10e1371102997a3a9c67df28772fd68910836d2eb1 SHA512 3798c6d5079ebdf4f447f62613340e46a6b593e0a97226b0aecc90889c6cd2f6f2ce36eb88395a12a0e27ff3803c7693f1c56443928914bfea134d8a75df8c91
+DIST voom-5.3.tar.gz 115841 BLAKE2B 6e88c4121b796a75ee623537483ff579acb4de73ff353408381ee64ce708cff1d7f8c45bdbe1e0c9761b5a17dd3aa54b3a0a2cf83873628bd1490e1524962ea2 SHA512 f51f30641d8b3d0ff5cd0d6b31cd1d8a15cb14f20f973ac83b9b5d046b94452e6e4e4ff0b28ce7842aa7f9b656a9dd631297aeae16ea75eea4411d911057873e
diff --git a/app-vim/voom/voom-5.3.ebuild b/app-vim/voom/voom-5.3.ebuild
new file mode 100644
index 000000000000..78f809834f6f
--- /dev/null
+++ b/app-vim/voom/voom-5.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="https://vim-voom.github.com/ https://www.vim.org/scripts/script.php?script_id=2657"
+SRC_URI="https://github.com/vim-voom/VOoM/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/VOoM-${PV}