summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gitgutter/Manifest1
-rw-r--r--app-vim/gitgutter/gitgutter-20171101.ebuild28
-rw-r--r--app-vim/gitgutter/gitgutter-99999999.ebuild3
3 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/gitgutter/Manifest b/app-vim/gitgutter/Manifest
index 266c3308d26e..cd689cb8e701 100644
--- a/app-vim/gitgutter/Manifest
+++ b/app-vim/gitgutter/Manifest
@@ -1 +1,2 @@
DIST gitgutter-20170222.tar.bz2 41819 SHA256 10ff5c0c4fc7c4fca857b98df92f0e94efb43c79b1077aaf7e7c54ea59e08e29 SHA512 970a956a839c2eaa05b699e8507b239d36ad623c40d3d05d9ce82320ec93ae733de2d40619898c5ff43074e2c8f95611b94879424767fac4f2b1fe2747611f4e WHIRLPOOL f201c0edbdf0978f0b48f2caed305343424bd2d97951902a0df9ce6f6c499ae3f0e506dc917a230db5f42c34022b170bb54baa682a2e75805af724b919d1f35c
+DIST gitgutter-20171101.tar.gz 43534 SHA256 ddb73159b438654c399842a92e2d6bcd3abe408ad493b8e9147ea475e4218b0e SHA512 24d8ad740931df17c2c67e2a2a13e3bba7c1205ba5543f5c11353e639876f4a54e69170dc0a946660ee2e3a23a110c90f4195fa9a1ddfff19163f00d88528219 WHIRLPOOL 08c261cb4eec09c9b226bd33285043f66c36dbe47827943f59f75f1f8a838c495aa3c5fbccccf1822e2f6297772e7252c96bf2126a3a771cd9ce5840b5940e3d
diff --git a/app-vim/gitgutter/gitgutter-20171101.ebuild b/app-vim/gitgutter/gitgutter-20171101.ebuild
new file mode 100644
index 000000000000..0cb5b2aebcc9
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20171101.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="1e60667322b7cd1bfcba98762fbba746a888d21a"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ default
+ rm LICENCE README* screenshot.png || die
+ rm -rf test || die
+}
diff --git a/app-vim/gitgutter/gitgutter-99999999.ebuild b/app-vim/gitgutter/gitgutter-99999999.ebuild
index de382720b670..0cb5b2aebcc9 100644
--- a/app-vim/gitgutter/gitgutter-99999999.ebuild
+++ b/app-vim/gitgutter/gitgutter-99999999.ebuild
@@ -8,6 +8,9 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/airblade/vim-gitgutter.git"
inherit git-r3
else
+ inherit vcs-snapshot
+ COMMIT_HASH="1e60667322b7cd1bfcba98762fbba746a888d21a"
+ SRC_URI="https://github.com/airblade/vim-gitgutter/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi