summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-xemacs/ebuild-mode/ebuild-mode-1.42.ebuild')
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.42.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.42.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.42.ebuild
new file mode 100644
index 000000000000..1288c724a3a0
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.42.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+ xemacs-elisp-make-autoload-file \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}