summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada/markdown/markdown-23.0.0-r1.ebuild')
-rw-r--r--dev-ada/markdown/markdown-23.0.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ada/markdown/markdown-23.0.0-r1.ebuild b/dev-ada/markdown/markdown-23.0.0-r1.ebuild
new file mode 100644
index 000000000000..010dd701d1ac
--- /dev/null
+++ b/dev-ada/markdown/markdown-23.0.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ADA_COMPAT=( gnat_2021 gcc_12 )
+inherit ada
+
+DESCRIPTION="Provides a markdown parser written in Ada"
+HOMEPAGE="https://github.com/AdaCore/markdown"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${ADA_DEPS}
+ dev-ada/gprbuild[${ADA_USEDEP}]
+ dev-ada/VSS[${ADA_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""