summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/bazelisk/bazelisk-1.19.0.ebuild')
-rw-r--r--dev-build/bazelisk/bazelisk-1.19.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-build/bazelisk/bazelisk-1.19.0.ebuild b/dev-build/bazelisk/bazelisk-1.19.0.ebuild
deleted file mode 100644
index 4cea472f3598..000000000000
--- a/dev-build/bazelisk/bazelisk-1.19.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="A user-friendly launcher for Bazel written in Go"
-HOMEPAGE="https://github.com/bazelbuild/bazelisk/"
-SRC_URI="
- https://github.com/bazelbuild/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-DOCS=( CONTRIBUTING.md README.md )
-
-src_compile() {
- mkdir -p bin || die
-
- local go_ldflags="-X main.BazeliskVersion=${PV}"
- local -a go_buildargs=(
- -ldflags "${go_ldflags}"
- -o bin
- )
- ego build "${go_buildargs[@]}"
-}
-
-src_install() {
- exeinto /usr/bin
- doexe "bin/${PN}"
-
- einstalldocs
-}