summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/gn/gn-0.2077.ebuild')
-rw-r--r--dev-build/gn/gn-0.2077.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-build/gn/gn-0.2077.ebuild b/dev-build/gn/gn-0.2077.ebuild
deleted file mode 100644
index b1cc9b6daab6..000000000000
--- a/dev-build/gn/gn-0.2077.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2018-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit ninja-utils python-any-r1 toolchain-funcs
-
-DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
-HOMEPAGE="https://gn.googlesource.com/"
-SRC_URI="https://dev.gentoo.org/~sultan/distfiles/dev-build/gn/${P}.tar.xz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="vim-syntax"
-
-BDEPEND="
- ${PYTHON_DEPS}
- app-alternatives/ninja
-"
-
-PATCHES=(
- "${FILESDIR}"/gn-gen-r5.patch
-)
-
-pkg_setup() {
- :
-}
-
-src_configure() {
- python_setup
- tc-export AR CC CXX
- unset CFLAGS
- set -- ${EPYTHON} build/gen.py --no-last-commit-position --no-strip --no-static-libstdc++ --allow-warnings
- echo "$@" >&2
- "$@" || die
- cat >out/last_commit_position.h <<-EOF || die
- #ifndef OUT_LAST_COMMIT_POSITION_H_
- #define OUT_LAST_COMMIT_POSITION_H_
- #define LAST_COMMIT_POSITION_NUM ${PV##0.}
- #define LAST_COMMIT_POSITION "${PV}"
- #endif // OUT_LAST_COMMIT_POSITION_H_
- EOF
-}
-
-src_compile() {
- eninja -C out gn
-}
-
-src_test() {
- eninja -C out gn_unittests
- out/gn_unittests || die
-}
-
-src_install() {
- dobin out/gn
- einstalldocs
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r misc/vim/{autoload,ftdetect,ftplugin,syntax}
- fi
-}