summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/gtk-doc-am/gtk-doc-am-1.33.2.ebuild')
-rw-r--r--dev-build/gtk-doc-am/gtk-doc-am-1.33.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-build/gtk-doc-am/gtk-doc-am-1.33.2.ebuild b/dev-build/gtk-doc-am/gtk-doc-am-1.33.2.ebuild
new file mode 100644
index 000000000000..626709418269
--- /dev/null
+++ b/dev-build/gtk-doc-am/gtk-doc-am-1.33.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gtk-doc"
+
+inherit gnome.org
+
+DESCRIPTION="Automake files from gtk-doc"
+HOMEPAGE="https://wiki.gnome.org/DocumentationProject/GtkDoc"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="!<dev-util/gtk-doc-${PV}"
+PDEPEND="virtual/pkgconfig"
+
+# This ebuild doesn't even compile anything, causing tests to fail when updating (bug #316071)
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins buildsystems/autotools/gtk-doc.m4
+}