summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/libtool/libtool-9999.ebuild')
-rw-r--r--dev-build/libtool/libtool-9999.ebuild36
1 files changed, 31 insertions, 5 deletions
diff --git a/dev-build/libtool/libtool-9999.ebuild b/dev-build/libtool/libtool-9999.ebuild
index 8c2693567e42..170c55f2db74 100644
--- a/dev-build/libtool/libtool-9999.ebuild
+++ b/dev-build/libtool/libtool-9999.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Please bump with dev-libs/libltdl.
# bug #225559
LIBTOOLIZE="true"
WANT_LIBTOOL="none"
-inherit autotools prefix multiprocessing
+inherit autotools flag-o-matic prefix multiprocessing
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/git/libtool.git"
inherit git-r3
+elif ! [[ $(( $(ver_cut 2) % 2 )) -eq 0 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
@@ -106,13 +108,37 @@ src_configure() {
export ac_cv_path_GREP="grep"
export ac_cv_path_lt_DD="dd"
- [[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"
+ local myeconfargs=(
+ # Split into dev-libs/libltdl
+ --disable-ltdl-install
- ECONF_SOURCE="${S}" econf ${myconf} --disable-ltdl-install
+ # Tests break otherwise (when porting to EAPI 8)
+ # https://lists.gnu.org/archive/html/bug-libtool/2014-10/msg00013.html
+ --enable-static
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && myeconfargs+=( "--program-prefix=g" )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
src_test() {
- emake check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+ (
+ # The testsuite is sensitive to warnings, expects static
+ # archives to really be archives (not compiler IR), etc.
+ strip-flags
+ filter-flags -fno-semantic-interposition
+ filter-flags '-Wstrict-aliasing=*' '-Werror=*'
+ filter-lto
+
+ emake -Onone check \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ FCFLAGS="${FCFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+ )
}
src_install() {