summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/mage/mage-1.15.0.ebuild')
-rw-r--r--dev-build/mage/mage-1.15.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-build/mage/mage-1.15.0.ebuild b/dev-build/mage/mage-1.15.0.ebuild
new file mode 100644
index 000000000000..579e852a78a7
--- /dev/null
+++ b/dev-build/mage/mage-1.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="make/rake like tool using go"
+HOMEPAGE="https://magefile.org"
+SRC_URI="https://github.com/magefile/mage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ GOBIN="${S}/bin" ego run bootstrap.go
+}
+
+src_install() {
+dobin bin/mage
+}