summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/muon')
-rw-r--r--dev-build/muon/Manifest2
-rw-r--r--dev-build/muon/metadata.xml19
-rw-r--r--dev-build/muon/muon-0.2.0-r1.ebuild70
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-build/muon/Manifest b/dev-build/muon/Manifest
new file mode 100644
index 000000000000..e57b5b1130cf
--- /dev/null
+++ b/dev-build/muon/Manifest
@@ -0,0 +1,2 @@
+DIST meson-docs-0.64.1-19-g39c6fa4bc.tar.gz 78525 BLAKE2B 19f4768e70f38f744de9bebfcc7416f8ab7f414693dc1f3e379bbbc8370e3d3187e6a9e311a08c054bdfaf1d15efd225558de7d41d688fc4c4a10e3215af85ae SHA512 59c986c4c4d545a6488cd74a2b6563b867716b74aab95fd19a745ce46a99fe5222232e132c80c5ed80f3e61d13e74cf2dc13b1b6d4638fd40a69d82d0d74faaa
+DIST muon-0.2.0.tar.gz 510533 BLAKE2B 6ec67f8875e84fbc2f23f412825dd47b820cd44e97a16d9ac0ab0ba9db6e755a604b66b79d3dbe13d99440daf21c2f0ccbe69661b1fb3c7df3f636c61a0e4dcb SHA512 b2e90048756bdc26bdea24fe227a87ad4d0e57176e217e22ea492a55229c62e2a70243f60af1e162e2dde8468fdda9662a32ea5cfadd69fab95a83499efa077b
diff --git a/dev-build/muon/metadata.xml b/dev-build/muon/metadata.xml
new file mode 100644
index 000000000000..244b76153784
--- /dev/null
+++ b/dev-build/muon/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <use>
+ <flag name="archive">
+ Enable extracting wraps using <pkg>app-arch/libarchive</pkg>.
+ </flag>
+ <flag name="libpkgconf">
+ Enable looking up packages via <pkg>dev-util/pkgconf</pkg>.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourcehut">~lattis/muon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-build/muon/muon-0.2.0-r1.ebuild b/dev-build/muon/muon-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..a6f3e8102624
--- /dev/null
+++ b/dev-build/muon/muon-0.2.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson python-any-r1
+
+COMMIT_HASH="${PV}"
+MESON_DOCS_TAR=meson-docs-0.64.1-19-g39c6fa4bc.tar.gz
+
+DESCRIPTION="A meson-compatible build system"
+HOMEPAGE="https://muon.build/"
+SRC_URI="
+ https://git.sr.ht/~lattis/muon/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz
+ man? (
+ https://mochiro.moe/wrap/${MESON_DOCS_TAR}
+ )
+"
+
+# Apache-2.0 for meson-docs
+LICENSE="GPL-3 man? ( Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="+archive +curl +libpkgconf +man"
+
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+DEPEND="
+ curl? ( net-misc/curl )
+ archive? ( app-arch/libarchive:= )
+ libpkgconf? ( dev-util/pkgconf:= )
+ man? ( app-text/scdoc )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ man? (
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use man && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if use man; then
+ mv "${WORKDIR}/meson-docs" "${S}/subprojects" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature curl libcurl)
+ $(meson_feature archive libarchive)
+ $(meson_feature libpkgconf)
+ $(meson_feature man docs)
+ -Dsamurai=disabled # patched version of samurai downloaded via wraps
+ -Dbestline=enabled # vendored bestline, an insignificant addition
+ )
+ meson_src_configure
+}