summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/rocm-cmake/rocm-cmake-5.7.1.ebuild')
-rw-r--r--dev-build/rocm-cmake/rocm-cmake-5.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-build/rocm-cmake/rocm-cmake-5.7.1.ebuild b/dev-build/rocm-cmake/rocm-cmake-5.7.1.ebuild
new file mode 100644
index 000000000000..706498981138
--- /dev/null
+++ b/dev-build/rocm-cmake/rocm-cmake-5.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocm-cmake/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocm-cmake/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocm-cmake-rocm-${PV}"
+fi
+
+DESCRIPTION="Radeon Open Compute CMake Modules"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm-cmake"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.2-license.patch
+)
+
+src_prepare() {
+ sed -e "/ROCM_INSTALL_LIBDIR/s:lib:$(get_libdir):" \
+ -i "${S}/share/rocm/cmake/ROCMInstallTargets.cmake" || die
+ cmake_src_prepare
+}