summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-build/tinycmmc/tinycmmc-0.1.0.ebuild')
-rw-r--r--dev-build/tinycmmc/tinycmmc-0.1.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild b/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild
new file mode 100644
index 000000000000..88aaf86e9ab9
--- /dev/null
+++ b/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="GPL-3+"
+SLOT="0"