summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/mm-common/mm-common-1.0.5.ebuild')
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/mm-common-1.0.5.ebuild b/dev-cpp/mm-common/mm-common-1.0.5.ebuild
new file mode 100644
index 000000000000..6c75fe90f747
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}