summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/mm-common')
-rw-r--r--dev-cpp/mm-common/Manifest1
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/Manifest b/dev-cpp/mm-common/Manifest
index a36eb86e908d..a4ab41c53277 100644
--- a/dev-cpp/mm-common/Manifest
+++ b/dev-cpp/mm-common/Manifest
@@ -1 +1,2 @@
DIST mm-common-1.0.2.tar.xz 271720 BLAKE2B 955a541290ffc9489a7061a1bdcc4b2cca7ac5e0a834a008b4e15173e3b6df38a5fb719f26fe6f83c073c025c7113bba3586f28a6341d37c7c98cfc93ec50f0a SHA512 106f3aae8bb836386148098037c52fef19c3779f5e8cfbafcbe52eca17340a6e2fb7e5c57154cc0a90b75c0bb23900a4274591a71d85f81391be780c53238de0
+DIST mm-common-1.0.3.tar.xz 272932 BLAKE2B 90459cfa75dbcab8bb9b0512f3f3f3703850000e4ea0124afb020c476fce9948ec0128d67510b13482d52f165ba0b7a8aa72e6b1afd4a88554fa52bc4f5598d2 SHA512 fdd79e9a2ca3d7ed311a6994bd04e7cbf2b1562c39968d309765ce3b5268128f98b3f1c08a434b460276e6d911d302a12ccc7aebd6cd67e4df13241a97034a70
diff --git a/dev-cpp/mm-common/mm-common-1.0.3.ebuild b/dev-cpp/mm-common/mm-common-1.0.3.ebuild
new file mode 100644
index 000000000000..035d8e988cdb
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}