summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
index d7e7355ddcf4..3f251a81fd24 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.6.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
@@ -27,11 +27,11 @@ src_configure() {
-DJSON_MultipleHeaders=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C doc
}
@@ -40,6 +40,6 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r doc/html
}