summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tree/files')
-rw-r--r--dev-cpp/tree/files/tree-2.62-test.patch17
-rw-r--r--dev-cpp/tree/files/tree-2.81-test.patch36
2 files changed, 36 insertions, 17 deletions
diff --git a/dev-cpp/tree/files/tree-2.62-test.patch b/dev-cpp/tree/files/tree-2.62-test.patch
deleted file mode 100644
index f7022426698b..000000000000
--- a/dev-cpp/tree/files/tree-2.62-test.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- test_tree.output 2008-08-28 11:16:11.000000000 +0100
-+++ test_tree.output.new 2009-04-15 19:06:53.174832287 +0100
-@@ -1,3 +1,8 @@
-+-----
-+hi
-+ 1
-+ 0
-+-----
- empty tree to begin with:
- 0
- 'more text' is sibling 2 in its sibling range
-@@ -309,3 +314,5 @@
- D
- I
- -----
-+G
-+H
diff --git a/dev-cpp/tree/files/tree-2.81-test.patch b/dev-cpp/tree/files/tree-2.81-test.patch
new file mode 100644
index 000000000000..c9e675dc7953
--- /dev/null
+++ b/dev-cpp/tree/files/tree-2.81-test.patch
@@ -0,0 +1,36 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,13 +1,6 @@
+-
+-%.o: %.cc
+- g++ -c -I. $^
+-
+-test1: test1.o
+- g++ -o test1 test1.o
+-
+-run_tests: test1 test1.req
+- ./test1 > test1.res
+- @diff test1.res test1.req
++check: test_tree
++ ./test_tree > mytest.output && \
++ diff -Nu test_tree.output mytest.output
+ @echo "*** All tests OK ***"
+
+ clean:
+--- a/test_tree.output
++++ b/test_tree.output
+@@ -1,3 +1,8 @@
++-----
++hi
++ 1
++ 0
++-----
+ empty tree to begin with:
+ 0
+ 'more text' is sibling 2 in its sibling range
+@@ -309,3 +314,5 @@
+ D
+ I
+ -----
++G
++H