summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/Manifest1
-rw-r--r--dev-cpp/glibmm/glibmm-2.76.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/glibmm/Manifest b/dev-cpp/glibmm/Manifest
index e5aecfc2b2d8..bf212b969a8d 100644
--- a/dev-cpp/glibmm/Manifest
+++ b/dev-cpp/glibmm/Manifest
@@ -1,2 +1,3 @@
DIST glibmm-2.66.5.tar.xz 7610516 BLAKE2B 766939ad6a5cd94bc642da7e9801ccb4f693d652ad4afcfc15b6e12a646b0d5d9c203a04328d13727f4e6c35730e7e9cc431f448618c75df305874dacaf0d7aa SHA512 3c1f91a1d91c23c5975254f5bf499f6752b6e3f1b056511133722cdfc853ffd2a94c375c0441dbb3f0933e7a257449ca4e365355ed580bd72d88c08d99a76684
DIST glibmm-2.74.0.tar.xz 7938292 BLAKE2B c089826f6a33c02d525d40bcb375249fd0aa1d238a2cce44b421389812345b57e41d93c8e6a5f37a8fa6f7800bdcc0d4da531ad0f3b3bf69b6f91ef7f9f496a8 SHA512 29c16a6c921fb135721c39b5328e0b45e09c500c65175199c1ec5ee75bdd5fb907072389c6980da3bf8fac0846235af5580f692706eb00d26947804daa1c99c9
+DIST glibmm-2.76.0.tar.xz 9295168 BLAKE2B 99e6e0776f945a245ea68ca39194c6cecaace282a9be31e27e65e07b8034963c814a6306b74817aeb82740fbc01a9e4ff3a0b4a8605da15a3cd0d3e72a86bb16 SHA512 be49599f5eb8eb5a1cef015cdb37af2564fcd1ea845aa4344804ca5f0f61468949711e25cefebb93219e1be37128ebfdd2a816324e752ac4395b4b87c072fc78
diff --git a/dev-cpp/glibmm/glibmm-2.76.0.ebuild b/dev-cpp/glibmm/glibmm-2.76.0.ebuild
new file mode 100644
index 000000000000..52324008bd75
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.76.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/glibmm"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.68"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="gtk-doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.73.2:2[${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:3[gtk-doc?,${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ gtk-doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+src_prepare() {
+ default
+
+ # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
+ sed -i -e '/giomm_tls_client/d' tests/meson.build || die
+
+ if ! use test; then
+ sed -i -e "/^subdir('tests')/d" meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwarnings=min
+ -Dbuild-deprecated-api=true
+ $(meson_native_use_bool gtk-doc build-documentation)
+ $(meson_use debug debug-refcounting)
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}