summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/functional-plus/Manifest1
-rw-r--r--dev-cpp/functional-plus/functional-plus-0.2.22.ebuild50
-rw-r--r--dev-cpp/functional-plus/metadata.xml16
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/functional-plus/Manifest b/dev-cpp/functional-plus/Manifest
new file mode 100644
index 000000000000..2100861432d6
--- /dev/null
+++ b/dev-cpp/functional-plus/Manifest
@@ -0,0 +1 @@
+DIST functional-plus-0.2.22.tar.gz 282821 BLAKE2B dd32e0c518d3b18dd7f31498579edb05cd8a73108c4720db560b48931ed50d8a1a970916d517d488188cdfd69d04d2a3bc6dbfe193b5b8adf114ee7a2938208c SHA512 399ff3012efd49e8617a0ae275e72bf13e87380e830f6ceb56f85fcda948d4ef252c5aa48f48f0a4a015874015d6e8ff442ac9395d523b4c946a01c17f2bd1b9
diff --git a/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild b/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild
new file mode 100644
index 000000000000..38e0d9137331
--- /dev/null
+++ b/dev-cpp/functional-plus/functional-plus-0.2.22.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Dobiasd/FunctionalPlus.git"
+else
+ SRC_URI="https://github.com/Dobiasd/FunctionalPlus/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Functional Programming Library for C++"
+HOMEPAGE="
+ https://www.editgym.com/fplus-api-search/
+ https://github.com/Dobiasd/FunctionalPlus
+"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+
+S="${WORKDIR}/FunctionalPlus-${PV}"
+
+fplus_test_wrapper() {
+ local BUILD_DIR="${WORKDIR}/${P}_build/test"
+ local CMAKE_USE_DIR="${S}/test"
+ $@
+}
+
+src_configure() {
+ cmake_src_configure
+ use test && fplus_test_wrapper cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use test && fplus_test_wrapper cmake_src_compile
+}
+
+src_test() {
+ fplus_test_wrapper cmake_src_test
+}
diff --git a/dev-cpp/functional-plus/metadata.xml b/dev-cpp/functional-plus/metadata.xml
new file mode 100644
index 000000000000..4dbdfbab0058
--- /dev/null
+++ b/dev-cpp/functional-plus/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/Dobiasd/FunctionalPlus/issues</bugs-to>
+ <remote-id type="github">Dobiasd/FunctionalPlus</remote-id>
+ </upstream>
+</pkgmetadata>