summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtest/gtest-1.10.0.ebuild8
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild6
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-cpp/gtest/gtest-1.10.0.ebuild b/dev-cpp/gtest/gtest-1.10.0.ebuild
index 02ca3c039b1a..0611441372a0 100644
--- a/dev-cpp/gtest/gtest-1.10.0.ebuild
+++ b/dev-cpp/gtest/gtest-1.10.0.ebuild
@@ -8,16 +8,18 @@ PYTHON_COMPAT=( python2_7 pypy )
inherit cmake-multilib python-any-r1
+MY_PV=1.10.x
+
if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/google/googletest"
else
if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- MY_PV=release-${PV}
+ URI_PV=v${MY_PV:-${PV}}
else
- MY_PV=${GOOGLETEST_COMMIT}
+ URI_PV=${MY_PV:=${GOOGLETEST_COMMIT}}
fi
- SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/google/googletest/archive/${URI_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
S="${WORKDIR}"/googletest-${MY_PV}
fi
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 02ca3c039b1a..826b660f7bc5 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -13,11 +13,11 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/google/googletest"
else
if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- MY_PV=release-${PV}
+ URI_PV=v${MY_PV:-${PV}}
else
- MY_PV=${GOOGLETEST_COMMIT}
+ URI_PV=${MY_PV:=${GOOGLETEST_COMMIT}}
fi
- SRC_URI="https://github.com/google/googletest/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/google/googletest/archive/${URI_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
S="${WORKDIR}"/googletest-${MY_PV}
fi