summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/barman/barman-2.12.ebuild')
-rw-r--r--dev-db/barman/barman-2.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-db/barman/barman-2.12.ebuild b/dev-db/barman/barman-2.12.ebuild
new file mode 100644
index 000000000000..c9ea0dc90668
--- /dev/null
+++ b/dev-db/barman/barman-2.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://downloads.sourceforge.net/project/pgbarman/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]"
+DEPEND=""