summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/barman')
-rw-r--r--dev-db/barman/Manifest1
-rw-r--r--dev-db/barman/barman-3.2.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
index 0ecd3afb2278..1ed353c380a5 100644
--- a/dev-db/barman/Manifest
+++ b/dev-db/barman/Manifest
@@ -1,2 +1,3 @@
DIST barman-2.12.tar.gz 1370978 BLAKE2B 2b44e153addab3fca7dbf572b03b2e22fe18f0960d98048aa145c64552a0de4cea977c423c268bfb9b822e44aaead3572ee350053049ab5459cc022d976eb4d0 SHA512 b4b479a03e5b770ba783af1d5645f6be2a19e2427cb58c6d9dfc6389240d4eeeec85401caa59c0d837a70f1cf67c0edbdb1539ecbd2f3de86285a122fc184320
DIST barman-2.19.tar.gz 1423229 BLAKE2B db316bad10774ff5825af7409ecc69cd502fe447dd91efc52c04ae23d8e5c21e682fcde351b23dea437817d6207765a6cba355399aea0c5799b0f34be55ee524 SHA512 042912aac1e02994fbbe270f9bf6f4340b9b7ba5b1fdb5d588bdf95098a970ed398e002d1d56731f9b96c8bd0c7e0b71463ab6c08517ce3c1f2c77d1a92618ff
+DIST barman-3.2.0.tar.gz 1463937 BLAKE2B 9daff4dc1374aef5dfd8eff48438464265189223c7b5e7b39045cdf39362c0d266e437f8ff98aac3c045ab94f09ecc59cd34dd7847b783649cf5e18ab3e85280 SHA512 73b86ce55a034bc1bb4f130ef06f2e05c4a7b5c221b49c9ff1cf2f3693e42a5b30613232e823c5b4a87d201bdc8c3b2137de3b189268354145cc3866526095ab
diff --git a/dev-db/barman/barman-3.2.0.ebuild b/dev-db/barman/barman-3.2.0.ebuild
new file mode 100644
index 000000000000..08998d1bf9e6
--- /dev/null
+++ b/dev-db/barman/barman-3.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
+
+RESTRICT="test" # missing azure sdk
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}